Risultati da 1 a 7 di 7
  1. #1
    New Member
    Data Registrazione
    24-06-2007
    Località
    campania-friuli-sardegna
    Messaggi
    45

    excell 2007 funzione =somma.se()

    Buongiorno, ho la necessità di sommare delle cifre entro determinate date . Praticamente ho un foglio di lavoro che nella colonna A ha delle date comprese dal 01/01/2010 al 31/12/2010 (ma non in ordine cronologico) e nella colonna H delle cifre, io devo sommare, per esempio, le cifre della colonna H comprese dal 02/02/2010 al 15/04/2010 oppure dal 01/01/2010 al 31/03/2010 e così via. Finora usavo la seguente formula: =SOMMA.SE(A1:A500;"<01/04/2009";H1:H500) poi per sommare un altro gruppo usavo la stessa formula e sottraevo il risultato precedente:=SOMMA.SE(A1:A500;"<01/07/2009";H1:H500)-la somma ottenuta prima. Funziona ma non credo sia il procedimento giusto.
    Vorrei sommare le cifre volute senza sottrarre i risultati precedenti.
    Ho provato con :=SOMMA.SE(A1:A500;">01/07/2009"O"<01/10/2010";H1:H500) ma mi da errore.
    Qualcuno potrebbe aiutarmi? Grazie

  2. #2
    Senior Member L'avatar di LS66
    Data Registrazione
    23-01-2007
    Messaggi
    438
    http://office.microsoft.com/it-it/ex... more criteria

    Sembra quindi che non sia possibile con Somma.Se indicare più di un criterio o utilizzare operatori logici.
    Devi ricorrere a Somma con successiva condizione SE, come indicato qui:

    http://office.microsoft.com/it-it/ex...ple conditions

    Ciao.

  3. #3
    Senior Member L'avatar di LS66
    Data Registrazione
    23-01-2007
    Messaggi
    438
    Sono stato precipitoso; il metodo indicato non sembra funzionare con le relazioni di disuguaglianza e con le date.

    Puoi provare questo
    Terzaghi - Excel e VBA
    sostituendo alla data di confronto ilriferimento ad una cella nella quale poni le date da confrontare:
    =MATR.SOMMA.PRODOTTO((A1:A4>G1)*(A1:A4<G2)*(B1:B4))
    Somma tra loro le celle nell'intervallo B1:B4 che corrispondono a celle di A1:A4 che rappresntano date comprese nell'intervallo da G1 a G2.

    Ciao.

  4. #4
    New Member
    Data Registrazione
    24-06-2007
    Località
    campania-friuli-sardegna
    Messaggi
    45
    Ciao, grazie della gentilezza e della rapidità, ho provato ma mi da #VALORE!
    Di solito quando vien fuori questa parolina sta ad indicare che i dati da trettare non corrispondono, devo riconvertirli? e come?

  5. #5
    Senior Member L'avatar di LS66
    Data Registrazione
    23-01-2007
    Messaggi
    438
    Io ho provato con la formula che ti ho indicato, ma non ottengo errori.
    Prova a riportare la formula utilizzata o, forse meglio, allega uno stralcio del foglio che utilizzi, così si può fare una prova.
    Ciao.

  6. #6
    New Member
    Data Registrazione
    24-06-2007
    Località
    campania-friuli-sardegna
    Messaggi
    45
    Ho trovato l'errore, essendo il file molto grande ho impiegato un pò di tempo a riguardarlo tutto, c'era un campo diverso.
    Funziona egregiamente, grazie mille per la disponibilità
    Ciao

  7. #7
    Senior Member L'avatar di LS66
    Data Registrazione
    23-01-2007
    Messaggi
    438

Segnalibri

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •